Ok I will give you the full rundown of everything that is happening. I have a TI 84+BE with a USB cable that came in the box with it. TI-Connect worked fine for about 1 year for me and then problems started occuring.

When I want to send a program with TI-Connect it will recognize the calculator and start sending but then I will get a '8C010000' error or a '8007005' error code. But when I want to send a program and an Application, if I send the application first with the program following then it will transfer both. So I have conquered that problem and now all I have to do is send an app with it.

The other problem is when I try to upload files from my calc to my computer with TI-Explorer. It recognizes the calc and everything and then it will start uploading and then bam I get another '8C010000' error code. Now I tried uploading an Application and guess what it worked. Next I tried uploading an application and a program with the application going first, but I cannot do that. So I am stuck with only uploading applications to my computer.

Can someone please help me erase this error once and for all because it really is beginning to annoy me! Mad
Have you tried reinstalling TI-Connect? Perhaps a complete uninstall/reinstall would help somehow...
Try downloading it from www.education.ti.com the version you have might not be the newest.
Or do away with TI-Connect and use Tilp instead
Kllrnohj wrote:
Or do away with TI-Connect and use Tilp instead

Somehow I saw that post coming.
This happened to me for a while too, reinstall the calc's OS and reinstall TI-Connect. This is what fixed it for me.
Kllrnohj wrote:
Or do away with TI-Connect and use Tilp instead

I still never got it work with my 84+SE but it my be worth a try.
Ok Jon has helped me fix this. The only problem is that there was not a Garbage Collect done. Jon told me that you cannot send or obtain programs from/to a (soft)corrupted memory. So anyone who ever has this problem. Just do a garbage collect. Then it should work.
Hehe, we were so wrong lol...

I'll add this to my list of fixes...

Actually, someone should start compiling a list of FAQs...
I was afraid that I had to re-install everything on my PC and on my 84 plus, until I tried garbage collect,
which is the first one in line if you press the G in the catalog menu.
It has worked perfectly.

Thank you!
Mine is now having the same problem. I garbage collected but it still isn't sending. Sad Mad
I had the same problem, really needed to load an app - cabamap. Garbage collection did not work, ram clearing/reset didn't work, deleteing all the objects didn't work, upgrading to latest (2.55) ti 84+ OS either. Running on other machines with win 7 and xp didn't help a bit.

The thing that worked was using TILP with additional extended 'timeout' parameter under linux. You can download linux make a live distro on usb, as I did, since I didn't have linux at hand.
You install tilp2 with apt-get o whatever, apply following patch:

wget https://launchpadlibrarian.net/79510370/new-devices-and-fixed-sysfs-warning.patch

sudo patch /lib/udev/rules.d/45-libticables.rules < new-devices-and-fixed-sysfs-warning.patch

then run

sudo tilp --calc=ti84+ --cable=DirectLink --timeout=3000

, drag the *.8xk file to your calculator - and - voila. It worked for me. I could pinpoint the previous error cause since tilp displays error log.

Although I succeded, I was quite irritated to waste 2 hours to transfer single program by trial and error technique.
fermath wrote:
Although I succeded, I was quite irritated to waste 2 hours to transfer single program by trial and error technique.

Just a heads up, this topic is well over 6 years old, the last post being over a year ago.

We appreciate your solution and hope others will find it helpful as well! Feel free to introduce yourself and partake in any active discussions you find relevant.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum