Hi (first time poster), not sure what I'm doing wrong, but the emulator doesn't seem to be loading properly? I'm choosing the rom file and the skin changes to the right calculator but then it still shows the "Load a ROM image to activate jstified" message.

Could I get some help with this please?

Huh. I don't think that this happens to only you. When I load a rom image for a TI-84 Plus, it will load. But when I load a rom of a TI-84 Plus CE (tested in CEmu), it fails to finish loading and I get the same results as above.
This happened to me the other day, and all I did was click the reset button on the emulator screen and reload the rom. Then it worked.

Hope this helped
Although I don't know a solution yet, I'd like to clarify that jsTIfied cannot emulate a TI 84 Plus CE. sangbum907, could you please tell us what calculator you're trying to emulate along with what browser you're using?
Oh so the CE won't work. But I had a similar problem with the Silver edition. It has worked before, but sometimes it will just load forever and never work. This only happens to me about 1/6 times. For details: this has happened on both a Windows 10 computer in Google Chrome and on a Macbook in Safari. Same rom file used each time.
Just tried this with my TI-84+SE ROM with no issues. Not implying your issues are invalid but that there are some variables we need to figure out first.

Can you guys open up the browser console/inspector and tell us if there are any errors? Have the console open prior to loading a ROM and be on the look out for any errors that may show up when you select/choose your ROM.

Mac mini (Late 2018)
macOS 10.15.0
Safari 13.0.2 (15608.
Well I'm not getting any problems right now on my Windows, and my Mac is unavailable for the next couple of weeks so there's not much I can show. The last time I tested was about a month, month and a half ago so my results might not be really important. It seems to be working just fine now.
Ok so I was using chrome at the time and I was trying to load the 84ce file I found; additionally I tried to to do this on my school's network (not sure if that has anything to do with it) but I just tried it online at home and used an 84plus rom and it ended up working fine.

Strangely enough, when I tried the 84plus rom on my school district network it didn't work....I'll try again tomorrow!

Thanks all for your prompt replies!
sangbum907 wrote:
Strangely enough, when I tried the 84plus rom on my school district network it didn't work....I'll try again tomorrow!

The district I.T. department may have disabled vital components that the emulator relies on, namely DOM Storage. Since we legally cannot upload your ROM to our servers, we upload the ROM to the browsers local storage.

This also unfortunately means that we can't cross save progress between computers or browsers so you'll need to download your programs from the emulator. In an ideal world, you'd use SourceCoder to create your programs then send them to the emulator to test them. As long as you don't clear your browsers cache, the ROM should persist.
OK! I think I figured it out! For some reason the emulator (which used to run on the district computers) no longer works on chrome for some reason; just tried working the emulator on edge and it worked! So hopefully I can get my kids to download edge and work the emulator from there.....Will give last update once I try this today!

Thanks again all for your help and support!
It doesn't appear to work on Firefox, either; I just tried two different ROMs; the v1.12 I dumped from my used TI-83 Plus, the day I got it, back on the 12th, and the v1.19 I just dumped a few minutes ago 'caise the 1.12 wouldn't work. I don't wanna use Edge... T_T

Edit: Never mind, just had to hide JsTIfied and expand it again, and it works. Thought it wasn't working because I was getting a completely black display on ROM upload.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum