Okay, so I feel kind of bad about complaining about the missing libraries, because I found them on GitHub. I can't find them again now I'm posting, but I have them on a flash drive.
CRITICAL BUG REPORT PLEASE READ ALL OF THIS SO YOU UNDERSTAND IT MATEO: After installing the libraries, I tried the USB support on my CE, and it worked! I was super happy and amazed and impressed that it worked. I took a couple minutes to find an 8xp file to transfer, and transferred it. When I exited the flash drive and ran the program (I believe it was S.A.M.M.), it didn't do what it was supposed to, just RAM reset. And worse, it had a ERROR: MEM screen that would just come back up if I pressed 1: QUIT. Eventually, I had to find a pencil to press the reset button on the back of the calculator, which got rid of the error mem screen, but somehow gobbled up all my RAM so there were only 16 bytes left (which was not enough to delete anything, just open up the program or mem menus.) I looked through the mem menu, and all of my data was archived. I made the calc do a ram reset from the mem menu, and it cleared the ram and fixed the problem. Unfortunately, I looked at the prgm menu from the OS, and it had only two (unarchived) programs on it with random titles and random tokens in them. This problem was remedied by opening Cesium, when all the programs I had on before the issue reappeared.
At this point, I started to suspect that there was something wrong with the boot code or ROM or whatever, so I made sure all the data was backed up to the computer with TI Connect, and did a factory reset. I reinstalled Cesium and the USB libraries, and then found (laboriously) all the programs I had from the flash drive, and reinstalled them with Cesium. Now, about 25% of the time I execute an assembly program (I have not experimented with BASIC programs) it goes back to the error mem screen that can only be gotten rid of by pressing the reset button on the back of the calc.

I suspect that the way Cesium writes from the flash drive to archive somehow corrupted the ROM of the calculator, so that whenever specific assembly instructions are executed, the calculator tries and fails to reboot, resulting in the error mem screen.
The USB support does work extremely well, though, and I forgot to mention that my suggestion is to execute the write instruction multiple times to avoid corruption.
You should probably post an issue on the github repo. What you've experienced, infinite memory error, isn't unheard-of. Try pressing and holding the reset button for at least two seconds. A quick press doesn't always completely reset the ram anymore. Which assembly programs are giving you problems? I'm pretty certain Cesium can't mess with the boot code, especially not on newer CEs. If your calculator passes OS validation then there's no issue there either. Do you have the same issue with these programs if you don't launch them via Cesium?
For some reason, executing the programs downloaded from the flash drive in Cesium not on Cesium didn't occur to me. ICE (downloaded from the drive) doesn't work, executed from the home or Cesium.
Okay, so I’ve done a bit more testing, and I think the problem is with the way Cesium handles the files from the drive, or the way it copies them over. The same programs always break the same ways.

This is how various programs work when downloaded from the flash drive with Cesium.
Calcuzap freezes the calc at the homescreen.
SolitiCE works fine executed from the homescreen, but when executed in Cesium, it ram resets the calc whenever you exit Cesium.
Banchor works fine, no problems that I can see.
ICE fails to both detect source programs and change the program editor.
S.A.M.M. Works fine, but since the world is so big, there could be bugs I failed to detect.
TI boy detected a corruption in Pokémon yellow, and won’t run it.
TI boy tries to run Space invaders, but crashes the calc and ram resets.
1010 works fine, aside from a couple random lines of binary on the screen.
A new release of Cesium, version 3.6.6, is available: https://github.com/mateoconlechuga/cesium/releases/latest

This version restores the app change hook and fixes some graphical issues.
how do i change my calc so it opens cesium on start up? ive been wanting to try out that poweron pswd feature
Press on+stat to turn off the calculator rather than using 2nd+on
I'm still having this issue as well. I tried clearing the Ram but still get the error message "RAM FREE" and it still clears my RAM every time I try to run an assembly program.
Which version of Cesium? Are you using 3.6.7?

Make sure to reset not just your ram, but archive too.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
» Goto page Previous  1, 2, 3 ... 22, 23, 24
» View previous topic :: View next topic  
Page 24 of 24
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum