I've recently started trying to build an app for my Ti-84+ Silver Edition, and I've run into a problem. I used Basic Builder to turn one of my Ti-BASIC programs into a .hex file. I then used the ti83+ SDK to save this as a .8xk app. When I try to test this in the SDK it works fine on my computer, but then I try to send the .8xk file to my calculator and I get an error "Incompatible Type". Any help? Thanks!
Which key did you use to sign your BASICBuilder app, Marvin? Was it the so-called "0104 key"? If so, I can't think of a reason why TI-Connect would refuse to send that signed app to your hardware calculator.
I think I realized that I needed to sign the app. I just used WAPPSIGN to sign it with the 10A key from here: http://brandonw.net/calculators/keys/.
But when I tried to send it to my calculator I got the error "USB communication error: Flash application has a bad signature" Should I use a different key?
Oh wait, I just signed it with the 104 key, and it worked!
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum