My nspire cx ii cas came in mail today, and I am trying to boot linux on it. Ndless works flawlessly.

With linuxloader2, I am able to boot the kernel (in a blazingly fast 16.5 seconds without even using noverii!) However, I have run into some problems and I hope the gurus here will be able to help.

1. The screen is rotated 90 degrees counterclockwise.
2. The .ll2 script that I wrote doesn't work for some reason (it says the required files doesn't exist or is empty), but when I input the exact same commands manually, it works fine.
3. The keypad only works in the bootloader and does not work in linux
4. It asks me to login for nan0cx, but I don't know what is the password

I am using the files from .Thanks in advance.
Did you pick the correct DTB file?
You can also put an os on a USB-stick, following this tutorial, which alllows you to at least solve the password problem.
If nothing helps and if nobody here can help you good, try asking on TI-planet. It is ok to write in English there. TI-planet has more nspire people than cemetech.
There's some ongoing work on improving support for newer Nspire models: .
Privacy_Dragon wrote:
Did you pick the correct DTB file?

I used an nspire cx dtb. I can't find a working dtb for cx ii online.

In , someone posted dtbs that are supposedly for the cx ii, but it simply doesn't display anything, unlike when using the cx dtb. Also, vogtinator says it works for HW-W+ (which should be the same LCD as the cx ii, I think)
Thanks for the help, everyone, I got it to work.

I used the files from Vogtinator at

Boots in about 15 seconds after the kernel starts; if you time it from when you start the bootloader, it's about 22 seconds. The keypad works.

iThe login credidentials are actually root with no password.
So I've played with it a little bit more and found a weird problem: it boots normally (with a few warnings) while connected to USB power (either PC or a wall plug works), but it freezes (not even the cursor blinks) in the middle of the boot process if it's not plugged in. Anyone know why could that happen?
Have you tried using the DTB file with the USB controller switched off - the one in this post by Voginator?
Ah, it works now. Thanks.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum