It is just as the title says, for some reason those 3 buttons (up, right, and down arrow) won't work. I've tried restarting by pressing the little button in the back, and also tried taking out the battery and putting it back but neither worked. None of the keys are sticky either. Any advice would be appreciated, thank you!
what happened? What did you do before it didn't work anymore? Crying
I once dropped my nspire on the ground, and the arrow square touchpad thing stopped working, but I was able to fix it by removing the battery. Did you drop yours?
If it's less than a year old then just return it for a new one.

The first thing to try is disassembling the calculator and wiping off the circuit board with isopropyl alcohol. Also, inspect the rubber key membrane for any damage. I'm skeptical that will resolve the issue but it's the only easy option.

The second thing would be to use a multi meter to figure out where along the circuit board a trace broke. Once you find the area, you'll need to solder a wire to bridge that gap. Do you have any experience with these tools?
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum