I got errors when I tried a makefile for CGDOOM but it told me that every header file in the directories were not found. These were the one's inside the CGDOOM folder but then I started fiddling around.

I wrote a simple program with a <stdio.h> header and tried to compile it with sh3eb-elf-gcc, it couldn't find it:

fatal error: stdio.h: No such file or directory
#include <stdio.h>
compilation terminated

EDIT: Forgot to mention that I tried <malloc.h>.
Okay so I figured I was being dumb because I forgot to use the dang makefile because seeing the compiler give errors about standard libraries threw me off. I ran make and it found <stdio.h>

However, when adding <malloc.h>, I got the same error. I am looking at the libraries supplied by libfxcg. I don't see anything there on "malloc.h". Should I use my own system's libraries in the path?
Should I use my own system's libraries in the path?
You should not: they're completely different libraries, for a completely different architecture (assuming you're running some flavor of Unix [Mac OS] or Linux on your machine). For malloc (and heap allocation), take a look at this Prizm wiki page and this associated forum discussion.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum