Over the last month or so, I have been working on a project which requires executing code in the high portion of memory ($C000-$FFFF). While the hardware on an actual TI-83+ usually keeps code from being executed up there, I used a routine I found online to disable that.

Despite the high RAM being unlocked, WabbitEmu does not seem to care. When the program counter reaches up that high, WabbitEmu halts the calculator and dumps me into the debugger. From there I can manually step through the program without issue (the calculator doesn't crash or anything), but I can't seem to make it run on it's own.

Does anyone know how I can disable this? If not, what other emulators do you recommend? I tried the online JS emulator and VTI83, but neither seem to work well enough.

Here is the code that I use to unlock the RAM

   in a,($02)
   jr nc,ramunlock_83p
   xor a
   out ($25),a
   out ($26),a
   ld a,%00000111
   out ($05),a
   xor a
   out ($16),a

EDIT: Nevermind, fixed it. Looks like you can just turn it off in options Neutral
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum