Hello, paging all oldskool TI-Z80 coders... Wink

I'm stuck with a very weird bug which only seems to occur on TI-82 (w/ CrASH). When I exit my program, all seems fine. But once I switch off the calc, and back on, it has a very low contrast (cursor is almost invisible), and the contrast can't be changed via [2nd]+dirkeys. Instead, it'll display a weird รบ where it would normally display the contrast level number. Briefly taking out the batteries will restore everything to normal. And as I said, builds of the same program on other models aren't affected by this.

I've tried to disable various "experimental" features in my program (polling port 3, switching to different ROM pages, etc), tried using EXIT_2_TIOS, nothing helps. So I'm suspecting there might be some problem with the highly optimized display driver I'm using.

Has anyone ever experienced something like this? Any ideas what could be
causing it? At the moment I don't want to make the program itself public, but if anybody wanted to look at the code, I could share a link via pm.
ROM pages ? o_O The TI-82 doesn't have ROM memory to begin with. You should disable every memory-related port write, since the TI-82 doesn't have any. Also, the HW is slightly different to the other z80 TI-83 or TI-83+-based calcs, although I don't know anything about it.
I've got it more or less figured out. It seems the last 7 bytes of text_mem shouldn't be messed with. Interesting find, haven't seen this documented anywhere.

Edit: Nope, I'm just too stupid to code.

@matref: Hmmm, what have you been smoking today? Of course the TI-82 has ROM, and yes, it's paged. So far, that part of my program hasn't been giving me any trouble Wink
First, I don't appreciate being talked to like that, and second, are we talking about the same TI-82 ?

This one doesn't have "accessible" ROM memory, as it has no archive mem (or I'm completely mistaken).
It has ROM, with page 0 accessible always and the remaining pages (however many make 128KB-page 0) in $4000-$7FFF. Pages can be switched by the user and by code in the ROM.

utz, what ROM version are you running? I can test stuff on other versions, if you link/send your program.
@matrefeytontias: Sorry, I didn't mean to offend you. I know you are an experienced coder, and I think you know that I know that Wink

But yes, we're talking about that TI-82, and yes, you are completely on the wrong page here (pun intended). ROM has nothing to do with archive mem. TI-82 ROM is 128 kb, how do you suppose it's addressed, if not via paging?

@CVSoft: Sorry, just plain boring 18.0 and 19.0. I might get back to you, but atm I think I'll just target the "common" ROM versions.
utz wrote:
@CVSoft: Sorry, just plain boring 18.0 and 19.0. I might get back to you, but atm I think I'll just target the "common" ROM versions.

16.0 and 17.0 (the only other versions standard CrASH supports) should act the same, and probably do. The "uncommon" ROM versions (before 16.0) currently don't have a working assembly shell, but that will change in the coming weeks Smile

But I feel we are digressing from the topic. If the behavior is this weird, there is not a whole lot we can do without seeing the code.

(sidenote: my 314th posf! )
Well, my bad. Sorry for wrong information then, mainly due to the fact that I never owned or used a TI-82 I guess.
This one doesn't have "accessible" ROM memory, as it has no archive mem (or I'm completely mistaken).

Strictly speaking, none of the calculators which provide archive or FlashApp memory have a ROM. Instead, they have Flash ROM Smile

The 80, 81, 82, 85, 86 have ROM, either mask ROM or OTP ROM, depending on the model / version.
What do you mean by the last 7 bytes of text_mem? If you mean 8108h-810Eh, I cannot imagine how touching that area could possibly make any difference to anyone, unless perhaps CrASH itself uses that space for some reason?

If you count 810Fh-8113h (textShadCur-textShadIns) as part of text_mem, then I can see how touching those bytes might conceivably cause a problem under some circumstances.
Don't worry, guys. After a more thorough examination I discovered that I'm a complete idiot. Razz Was writing to 8008h ff. instead of 8108ff. Ouch!
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum